Re: [PATCH] linux/kernel.h: merge ARRAY_AND_SIZE defines

From: Alex Elder
Date: Wed Dec 24 2014 - 09:02:38 EST

On 12/23/2014 11:44 PM, Joe Perches wrote:
> On Wed, 2014-12-24 at 14:38 +0900, Masahiro Yamada wrote:
>> ARRAY_AND_SIZE is a useful macro. Its definition is already
>> duplicated in some headers. Move it to include/linux/kernel.h.
> I think it's not a good/useful macro and
> would prefer the uses expanded instead.

For what it's worth, I agree. -Alex

> The uses of ARRAY_AND_SIZE in structure
> definitions aren't particularly bad, but the
> ARRAY_AND_SIZE uses that hide the number of
> arguments in a function I think are suboptimal.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at