[PATCH 0/3] CCF fixes/cleanup for per-user series

From: Stephen Boyd
Date: Thu Feb 05 2015 - 19:19:34 EST


Here are some fixes from today's dive into the fallout from the
per-user constraints patches. We should do a final sweep later
to rename local variables with type struct clk_core to core.

Stephen Boyd (3):
clkdev: Always allocate a struct clk and call __clk_get() w/ CCF
clk: Rename child_node to clks_node to avoid confusion
clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider()

drivers/clk/clk-conf.c | 6 ++---
drivers/clk/clk.c | 59 ++++++++++++++++++++++++++++----------------------
drivers/clk/clk.h | 16 ++++++++++----
drivers/clk/clkdev.c | 55 ++++++++--------------------------------------
include/linux/clkdev.h | 5 ++++-
5 files changed, 61 insertions(+), 80 deletions(-)

--
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/