Re: [PATCH] USB: image: use msecs_to_jiffies for time conversion

From: Nicholas Mc Guire
Date: Fri Feb 06 2015 - 08:37:05 EST


On Fri, 06 Feb 2015, Sergei Shtylyov wrote:

> Hello.
>
> On 2/6/2015 12:50 PM, Nicholas Mc Guire wrote:
>
>> This is only an API consolidation and should make things more readable
>> it replaces var * HZ / 1000 by msecs_to_jiffies(var).
>
>> Signed-off-by: Nicholas Mc Guire <hofrat@xxxxxxxxx>
>> ---
>
>> Note that the indentation is not aligned with the correct ( here due to
>> lines going over 80 char - not sure if this is the right way to resolve
>> this (this file has quite a few coding style issues).
>
>> Patch was only compile tested with x86_64_defconfig + CONFIG_USB_MDC800=m
>
>> Patch is against 3.19.0-rc7 (localversion-next is -next-20150204)
>
>> drivers/usb/image/mdc800.c | 11 +++++++----
>> 1 file changed, 7 insertions(+), 4 deletions(-)
>
>> diff --git a/drivers/usb/image/mdc800.c b/drivers/usb/image/mdc800.c
>> index a62865a..3a72e8f 100644
>> --- a/drivers/usb/image/mdc800.c
>> +++ b/drivers/usb/image/mdc800.c
> [...]
>> @@ -743,8 +744,9 @@ static ssize_t mdc800_device_read (struct file *file, char __user *buf, size_t l
>> mutex_unlock(&mdc800->io_lock);
>> return len-left;
>> }
>> - wait_event_timeout(mdc800->download_wait, mdc800->downloaded,
>> - TO_DOWNLOAD_GET_READY*HZ/1000);
>> + wait_event_timeout(mdc800->download_wait,
>> + mdc800->downloaded,
>> + msecs_to_jiffies(TO_DOWNLOAD_GET_READY));
>
> Don't indent with spaces (you're not aligning to open paren anyway),
> use the final tab instead, please.
>
thanks ! In the diff output that problem is actually not well visible.
was not really clear on how to do this properly - the problem with
using the last tab stop is that you then get the following code

wait_event_timeout(mdc800->download_wait,
mdc800->downloaded,
msecs_to_jiffies(TO_DOWNLOAD_GET_READY));
mdc800->downloaded = 0;

which semed really bad and

wait_event_timeout(mdc800->download_wait,
mdc800->downloaded,
msecs_to_jiffies(TO_DOWNLOAD_GET_READY));
mdc800->downloaded = 0;

makes it atleast somewhat readable. If I indent a full tab ghen it goes over
80 char.

So in this case - should one use the last tab-stop anyway ?

thx!
hofrat
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/