Re: [PATCH 1/1] ARM: dts: Use more descriptive names for Exynos5420 PDs

From: Sergei Shtylyov
Date: Tue Feb 10 2015 - 07:21:14 EST

On 2/10/2015 3:17 PM, Krzysztof Kozlowski wrote:

Additionally (on Arndale Octa):

$ cat /sys/kernel/debug/pm_genpd/pm_genpd_summary
domain status slaves
/device runtime status
power-domain on
/devices/platform/amba/3880000.adma suspended
power-domain off
power-domain off
power-domain off
power-domain off
power-domain off

This really is not helpful. From the power domain debugfs code it is
complicated to extract of_node of power domain.

You shouldn't need it.

It is easier to print
the name of power domain. But wait... all names are the same! :) So
why do we have the name in the first place?

I'm not sure why the full platform device names aren't printed -- they
should all be different.

This debugfs code iterates over list of generic_pm_domains (gpd_list). I
cannot find function for translating from genpd to its platform device
so only genpd->name can be printed.

Then why power domains aren't just named with the platform device names?

Best regards,

WBR, Sergei

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at