Re: [PATCH 07/11] x86: entry_64.S: rename save_paranoid to paranoid_entry, no code changes

From: Andy Lutomirski
Date: Wed Feb 11 2015 - 15:39:51 EST

On Wed, Jan 14, 2015 at 1:48 PM, Denys Vlasenko <dvlasenk@xxxxxxxxxx> wrote:
> This patch does a lot of cleanup in comments and formatting,
> but it does not change any code.
> Rename save_paranoid to paranoid_entry: this makes naming
> similar to its "non-paranoid" sibling, error_entry,
> and to its counterpart, paranoid_exit.
> Use the same CFI annotation atop paranoid_entry and error_entry.
> Fix irregular indentation of assembler operands.
> Add/fix comments on top of paranoid_entry and error_entry.
> Remove stale comment about "oldrax".
> Make comments about "no swapgs" flag in ebx more prominent.
> Deindent wrongly indented top-level comment atop paranoid_exit.
> Indent wrongly deindented comment inside error_entry.
> Signed-off-by: Denys Vlasenko <dvlasenk@xxxxxxxxxx>

Looks good. Will apply once the rest of the series is ready.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at