Re: [PATCH] [SCSI] sg: fix read() error reporting

From: Douglas Gilbert
Date: Thu Feb 12 2015 - 18:31:58 EST


On 15-02-11 01:13 PM, Tony Battersby wrote:
On 02/11/2015 12:45 PM, Douglas Gilbert wrote:
On 15-02-11 11:32 AM, Tony Battersby wrote:
Fix SCSI generic read() incorrectly returning success after detecting an
error.

Cc: <stable@xxxxxxxxxxxxxxx>
Signed-off-by: Tony Battersby <tonyb@xxxxxxxxxxxxxxx>
---

For inclusion in kernel 3.20.

--- linux-3.19.0/drivers/scsi/sg.c.orig 2015-02-08 21:54:22.000000000 -0500
+++ linux-3.19.0/drivers/scsi/sg.c 2015-02-10 09:26:09.000000000 -0500
@@ -546,7 +546,7 @@ static ssize_t
sg_new_read(Sg_fd * sfp, char __user *buf, size_t count, Sg_request * srp)
{
sg_io_hdr_t *hp = &srp->header;
- int err = 0;
+ int err = 0, err2;
int len;

if (count < SZ_SG_IO_HDR) {
@@ -575,8 +575,8 @@ sg_new_read(Sg_fd * sfp, char __user *bu
goto err_out;
}
err_out:
- err = sg_finish_rem_req(srp);
- return (0 == err) ? count : err;
+ err2 = sg_finish_rem_req(srp);
+ return err ? : err2 ? : count;
Tony,
Your point is well made.

I just don't like that last line, using a gcc extension that
hasn't even made it into C11 (or C++11). Wouldn't:
return err ? err : (err2 ? err2 : count);

be a bit better? I think the following snippet makes the intent
clear but would it generate any more code:
if (err || err2)

An improvement on the above line would be:
if (unlikely(err || err2))

return err ? err : err2;
else
return count;


Another approach is to return the good path prior to the
err_out label. This would require two calls to
sg_finish_rem_req().

However Tony's clean-up is sufficient.

I checked before submitting, and the foo ? : bar construct is already
used at least 455 times in the kernel, so it is nothing new.

find linux-3.19 -type f -name "*.[ch]" | xargs grep '\? :' | wc -l
455

But you are probably right; I think that with such small variable names
your version is more readable due to the nesting. Updated patch below.

---

Fix SCSI generic read() incorrectly returning success after detecting an
error.

Cc: <stable@xxxxxxxxxxxxxxx>
Signed-off-by: Tony Battersby <tonyb@xxxxxxxxxxxxxxx>

Acked-by: Douglas Gilbert <dgilbert@xxxxxxxxxxxx>

---

--- linux-3.19.0/drivers/scsi/sg.c.orig 2015-02-08 21:54:22.000000000 -0500
+++ linux-3.19.0/drivers/scsi/sg.c 2015-02-11 13:02:56.000000000 -0500
@@ -546,7 +546,7 @@ static ssize_t
sg_new_read(Sg_fd * sfp, char __user *buf, size_t count, Sg_request * srp)
{
sg_io_hdr_t *hp = &srp->header;
- int err = 0;
+ int err = 0, err2;
int len;

if (count < SZ_SG_IO_HDR) {
@@ -575,8 +575,8 @@ sg_new_read(Sg_fd * sfp, char __user *bu
goto err_out;
}
err_out:
- err = sg_finish_rem_req(srp);
- return (0 == err) ? count : err;
+ err2 = sg_finish_rem_req(srp);
+ return err ? err : (err2 ? err2 : count);
}

static ssize_t

--

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/