Re: [RFC 2/3] x86: Switch all C consumers of kernel_stack to this_cpu_sp0

From: Andy Lutomirski
Date: Fri Feb 27 2015 - 14:57:13 EST


On Feb 27, 2015 8:13 AM, "Denys Vlasenko" <dvlasenk@xxxxxxxxxx> wrote:
>
> On 02/27/2015 01:07 AM, Andy Lutomirski wrote:
> > This will make modifying the semantics of kernel_stack easier.
> >
> > Cc: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
> > Cc: Boris Ostrovsky <boris.ostrovsky@xxxxxxxxxx>
> > Cc: Rusty Russell <rusty@xxxxxxxxxxxxxxx>
> > Signed-off-by: Andy Lutomirski <luto@xxxxxxxxxxxxxx>
> > ---
> > arch/x86/include/asm/thread_info.h | 3 +--
> > arch/x86/kernel/traps.c | 2 +-
> > 2 files changed, 2 insertions(+), 3 deletions(-)
> >
> > diff --git a/arch/x86/include/asm/thread_info.h b/arch/x86/include/asm/thread_info.h
> > index e82e95abc92b..92549053d86d 100644
> > --- a/arch/x86/include/asm/thread_info.h
> > +++ b/arch/x86/include/asm/thread_info.h
> > @@ -163,8 +163,7 @@ DECLARE_PER_CPU(unsigned long, kernel_stack);
> > static inline struct thread_info *current_thread_info(void)
> > {
> > struct thread_info *ti;
> > - ti = (void *)(this_cpu_read_stable(kernel_stack) +
> > - KERNEL_STACK_OFFSET - THREAD_SIZE);
> > + ti = (void *)(this_cpu_sp0() - THREAD_SIZE);
> > return ti;
> > }
> >
> > diff --git a/arch/x86/kernel/traps.c b/arch/x86/kernel/traps.c
> > index c74f2f5652da..d287ea779728 100644
> > --- a/arch/x86/kernel/traps.c
> > +++ b/arch/x86/kernel/traps.c
> > @@ -174,7 +174,7 @@ void ist_begin_non_atomic(struct pt_regs *regs)
> > * will catch asm bugs and any attempt to use ist_preempt_enable
> > * from double_fault.
> > */
> > - BUG_ON(((current_stack_pointer() ^ this_cpu_read_stable(kernel_stack))
> > + BUG_ON(((current_stack_pointer() ^ (this_cpu_sp0() - 1))
> > & ~(THREAD_SIZE - 1)) != 0);
>
> While we are at it, I propose a more readable version of this check:
>
> BUG_ON(this_cpu_sp0() - current_stack_pointer() >= THREAD_SIZE);
>
> Yes, I am aware that it is not equivalent to the existing condition
> - it uses the fact that this_cpu_sp0(), previous check
> wasn't making that assumption. But that assumption is true,
> so shouldn't be a problem.

You're missing an absolute value in here, though. This isn't a check
for overflow; it's a check that we aren't on an IST or other per cpu
stack.

--Andy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/