Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

From: Chentao (Boby)
Date: Fri Mar 06 2015 - 04:33:43 EST




On 2015/3/5 0:32, Joe Perches wrote:
On Wed, 2015-03-04 at 18:32 +0000, Tao Chen wrote:
Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr sentences and DPRINTK.
Also fixed up some comments just as eliminate redundant white spaces and format the code.
These will make the code easier to read.

It'd probaby be better just to use pr_fmt
before any include and remove all the DRV_PRV uses

#define pr_fmt(fmt) "xen-pvscsi: " fmt

diff --git a/drivers/xen/xen-scsiback.c b/drivers/xen/xen-scsiback.c
[]
@@ -69,8 +69,10 @@
#include <xen/interface/grant_table.h>
#include <xen/interface/io/vscsiif.h>

+#define DRV_PFX "xen-pvscsi: "
#define DPRINTK(_f, _a...) \
- pr_debug("(file=%s, line=%d) " _f, __FILE__ , __LINE__ , ## _a)
+ pr_debug(DRV_PFX "(file=%s, line=%d) " _f, \
+ __FILE__ , __LINE__ , ## _a)

I'd also remove DPRINTK and just use pr_debug directly
as dynamic_debug can emit file and line as desired.


Joe, your suggested code is like below

#ifdef pr_fmt
#undef pr_fmt
#endif
#define pr_fmt(fmt) "xen-pvscsi: " fmt

Then replace all DPRINTK with pr_debug.

Am I right?


@@ -84,7 +86,7 @@ struct ids_tuple {

struct v2p_entry {
struct ids_tuple v; /* translate from */
- struct scsiback_tpg *tpg; /* translate to */
+ struct scsiback_tpg *tpg; /* translate to */

superfluous change.



.


I'm sorry, I made a mistake here. I will modify it in my next patch.

Thanks, Joe.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/