Re: [PATCH v4 3/6] Documentation: DT: Document twl4030-madc-battery bindings
From: Sebastian Reichel
Date: Wed Mar 11 2015 - 15:37:22 EST
On Wed, Mar 11, 2015 at 10:43:17AM -0700, Tony Lindgren wrote:
> No no, "capacity-uah" is what we should use, but you need an ack from
> the battery and device tree people that this is OK. Let's not add
> "ti,capacity-uahâ as that can obviously be a generic property.
I'm okay with capacity-uah.
> > [...]
> Oh if they are battery spicific, then ideally we'd have generic batery
> voltage to capacity maps property rather than a custom ti specific
> To avoid extra hassles later on, maybe you could submit a generic
> binding patch only documenting it to the battery people and the device
> tree people? That will make it easier to maintain this driver in the
> long run.
Actually the proper way would be to differentiate between the
battery and the measurement chip / adc and that should be
implemented in the long run. The kernel's power supply framework
is not yet ready for it, though.
measures = <&battery>;
charges = <&battery>;
Since infrastructure for generic bindings is missing, I think its
best to have the vendor properties for now and map this to generic
properties, once they have been specified.
Description: Digital signature