Re: [PATCH V5 00/25] perf tools: Introduce an abstraction for Instruction Tracing

From: Adrian Hunter
Date: Thu Mar 12 2015 - 16:51:27 EST


On 11/03/2015 9:33 p.m., Arnaldo Carvalho de Melo wrote:
Em Wed, Mar 11, 2015 at 05:55:37PM +0200, Adrian Hunter escreveu:
On 7/03/2015 11:06 p.m., Adrian Hunter wrote:
Hi

Here is V5 of some more preparatory patches for Intel PT
that introduce an abstraction for Instruction tracing.

The Intel PT driver is not yet in tip.

Peter, could we please have Alex's 14 patches applied to
tip?

Peter, I know you are really busy, but it would be helpful to know
what you plan to do?


The master branch of the tree:

git://git.infradead.org/users/ahunter/linux-perf.git

contains these patches plus Intel PT and BTS and the kernel driver.

Arnaldo, I have re-based on tip because of the conflict
with your ordered-events changes. I will have a closer look
at that next week.

I took a closer look and resolved the conflict by introducing:

static int perf_session__deliver_ordered_event(struct ordered_events *oe,
struct ordered_event *event,
struct perf_sample *sample)
{
struct perf_session *session =
container_of(oe, struct perf_session, ordered_events);

return perf_session__deliver_event(session, event->event, sample,
oe->tool, event->file_offset);
}

That would clash again, as in my tree I have it as:

static int perf_session__deliver_event(struct ordered_events *oe,
struct ordered_event *event,
struct perf_sample *sample)
{
return machines__deliver_event(oe->machines, oe->evlist, event->event,
sample, oe->tool, event->file_offset);
}

Which is a misnomer really, as by now it has nothing to do with a
perf_session, its all about ordered_event to a ordered_events.

We'll get that sorted out eventually. Sorry for the flux, but its trying
to get it to a better, more fine grained state.

I will send another revision of the patch set, but I am also
considered renaming everything from "itrace" to something more
generic. Possibly "auxtrace" or "hwtrace". Any preferences?

That should match whatever name is used for the kernel facility it will
handle.... both auxtrace and hwtrace looks too ambiguous...

cputrace perhaps?

"cputrace" sounds a bit like what perf already does. I am leaning toward
"auxtrace" which got Andi's vote.

It is possible Peter is waiting on perf tools patches before
moving the kernel driver patches. Are you amenable to taking
more of my patches or are you waiting on the Alex's driver patches?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/