Re: [PATCH] fs/pstore: Optimization function ramoops_init_przs

From: long.wanglong
Date: Tue Mar 17 2015 - 21:35:21 EST


On 2015/3/18 1:39, Kees Cook wrote:
> On Tue, Mar 17, 2015 at 2:31 AM, Wang Long <long.wanglong@xxxxxxxxxx> wrote:
>> The value of cxt->record_size does not change in the loop,
>> so this patch optimize the assign statement by moving
>> it to outer.
>>
>> Signed-off-by: Wang Long <long.wanglong@xxxxxxxxxx>
>> ---
>> fs/pstore/ram.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/fs/pstore/ram.c b/fs/pstore/ram.c
>> index 44a549b..2105a16 100644
>> --- a/fs/pstore/ram.c
>> +++ b/fs/pstore/ram.c
>> @@ -373,6 +373,7 @@ static int ramoops_init_przs(struct device *dev, struct ramoops_context *cxt,
>> {
>> int err = -ENOMEM;
>> int i;
>> + size_t sz;
>>
>> if (!cxt->record_size)
>> return 0;
>> @@ -393,9 +394,8 @@ static int ramoops_init_przs(struct device *dev, struct ramoops_context *cxt,
>> goto fail_prz;
>> }
>>
>> + sz = cxt->record_size;
>> for (i = 0; i < cxt->max_dump_cnt; i++) {
>> - size_t sz = cxt->record_size;
>> -
>> cxt->przs[i] = persistent_ram_new(*paddr, sz, 0,
>> &cxt->ecc_info,
>> cxt->memtype);
>> --
>> 1.8.3.4
>>
>
> Actually, can't we drop sz entirely and just use cxt->record_size in its place?
>
> -Kees
>
I agree with you.
drop sz entirely and use cxt->record_size in its place can improve readability.

I will send another patch.

Best Regards

Wang Long

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/