Re: [PATCH v5 0/5] Add support for Fujitsu USB host controller

From: Sneeker Yeh
Date: Wed Mar 18 2015 - 12:02:58 EST


2015-03-11 5:30 GMT+08:00 Felipe Balbi <balbi@xxxxxx>:
> On Sun, Feb 22, 2015 at 12:25:35PM +0800, Sneeker Yeh wrote:
>> These patches add support for XHCI compliant Host controller found
>> on Fujitsu Socs, and are based on http://lwn.net/Articles/629162/
>> The first patch is to add Fujitsu glue layer of Synopsis DesignWare USB3 driver
>> and last four patch is about quirk implementation of errata in Synopsis
>> DesignWare USB3 IP.
>>
>> Patch 1 introduces a quirk with device disconnection management necessary
>> Synopsys Designware USB3 IP with versions < 3.00a and hardware configuration
>> DWC_USB3_SUSPEND_ON_DISCONNECT_EN=1. It solves a problem where without the
>> quirk, that host controller will die after a usb device is disconnected from
>> port of root hub.
>>
>> Patch 2 is to set Synopsis quirk in xhci platform driver based on xhci platform
>> data.
>>
>> Patch 3 is to add a revison number 2.90a and 3.00a of Synopsis DesignWare USB3
>> IP core driver.
>>
>> Patch 4 introduces using a quirk based on a errata of Synopsis
>> DesignWare USB3 IP which is versions < 3.00a and has hardware configuration
>> DWC_USB3_SUSPEND_ON_DISCONNECT_EN=1, which cannot be read from software. As a
>> result this quirk has to be enabled via platform data or device tree.
>>
>> Patch 5 introduces Fujitsu Specific Glue layer in Synopsis DesignWare USB3 IP
>> driver.
>>
>> Successfully tested on Fujitsu mb86s7x board.
>>
>> Changes since v4 (RFC):
>> [https://lkml.org/lkml/2015/2/17/13]
>> - based on Felipe's comment, rename dwc3-mb86s70.c to dwc3-fujitsu.c which is
>> more generic.
>> - based on Mathias's comment, remove unhelpful comment, and change the
>> function name of xhci_try_to_clear_csc() to xhci_late_csc_clear_quirk()
>> which is more appropriate.
>>
>> Changes since v3 (RFC):
>> [https://lkml.org/lkml/2015/1/25/8]
>> - based on Mathias's comment, fix bug and using xhci_port_state_to_neutral()
>> helper function to mask out some RW1C bits, prevent writing back all the
>> bits read from the PORTSC register.
>>
>> Changes since v2 (RFC):
>> [https://lkml.org/lkml/2015/1/19/55]
>> - based on Felipe's comment, re-order patches to avoid breaking bisectability,
>> - based on Felipe's comment, add comment to structure's member, and sort it
>> alphabetically,
>> - based on Felipe's comment, add another v2.90 revision number in dwc3 IP.
>>
>> Changes since v1 (RFC):
>> [https://lkml.org/lkml/2014/12/15/929]
>> - based on Arnd's comment, remove entire unnecessary Fujitsu EHCI/OHCI glue,
>> - based on Felipe's comment, fix mis-using of runtime-pm API and setting dma
>> mask, remove unnecessary comment, and refactor suspend/resume handler in
>> Fujitsu Specific Glue layer in dwc3,
>> - based on Felipe's comment, add more commit log and comments in Synopsis
>> quirk implementation, and separate it into four patches.
>>
>> Sneeker Yeh (5):
>> xhci: add a quirk for device disconnection errata for Synopsis
>> Designware USB3 core
>> xhci: Platform: Set Synopsis device disconnection quirk based on
>> platform data
>> usb: dwc3: add revision number DWC3_REVISION_290A and
>> DWC3_REVISION_300A
>> usb: dwc3: Add quirk for Synopsis device disconnection errata
>> usb: dwc3: add Fujitsu Specific Glue layer
>
> Mathias, if you want me to take this series I need your Acked-by,
> otherwise I can give you mine, just let me know.

Hi Mathias, I hope I'm not imposing here,
but would you let me know if there's any further comment for the patchset.

Much appreciate,
Sneeker

>
> --
> balbi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/