On Thu, Apr 16, 2015 at 08:36:20AM +1000, Dave Chinner wrote:
Bikeshedding: I think this would be better suited to inode_dio_begin()
and inode_dio_end() because now we are trying to say "this is where
the DIO starts, and this is where it ends". It's not really
"reference counting" interface, we're trying to annotate the
boundaries of where DIO iis protected against truncate....
And while we are at, inode_dio_begin() could be static inline just fine.