Re: [PATCH v4 3/17] video: fbdev: gbefb: use arch_phys_wc_add() and devm_ioremap_wc()

From: Ingo Molnar
Date: Fri May 29 2015 - 02:41:59 EST



* Luis R. Rodriguez <mcgrof@xxxxxxxxxxxxxxxx> wrote:

> + gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
> + gbe_mem_size);

> + gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
> + &gbe_dma_addr, GFP_KERNEL);

> + par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);

> + arch_phys_wc_del(par->wc_cookie);

> + arch_phys_wc_del(par->wc_cookie);

Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is
coherent across the various APIs?

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/