Re: [PATCH] lsm: rename duplicate labels in LSM_AUDIT_DATA_TASK audit message type

From: Paul Moore
Date: Fri May 29 2015 - 15:15:44 EST


On Wednesday, April 15, 2015 02:08:25 PM Richard Guy Briggs wrote:
> The LSM_AUDIT_DATA_TASK pid= and comm= labels are duplicates of those at the
> start of this function with different values. Rename them to their object
> counterparts opid= and ocomm= to disambiguate.
>
> Signed-off-by: Richard Guy Briggs <rgb@xxxxxxxxxx>
> ---
> security/lsm_audit.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)

Applied, thanks.

> diff --git a/security/lsm_audit.c b/security/lsm_audit.c
> index b526ddc..3323144 100644
> --- a/security/lsm_audit.c
> +++ b/security/lsm_audit.c
> @@ -282,7 +282,7 @@ static void dump_common_audit_data(struct audit_buffer
> *ab, pid_t pid = task_pid_nr(tsk);
> if (pid) {
> char comm[sizeof(tsk->comm)];
> - audit_log_format(ab, " pid=%d comm=", pid);
> + audit_log_format(ab, " opid=%d ocomm=", pid);
> audit_log_untrustedstring(ab,
> memcpy(comm, tsk->comm, sizeof(comm)));
> }

--
paul moore
security @ redhat

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/