Re: [PATCH 1/4] x86/asm/entry: Rename compat syscall entry points

From: Borislav Petkov
Date: Mon Jun 08 2015 - 04:47:52 EST


On Mon, Jun 08, 2015 at 10:34:58AM +0200, Ingo Molnar wrote:
> Rename the following system call entry points:
>
> ia32_cstar_target -> entry_SYSCALL_compat
> ia32_syscall -> entry_INT80_compat
>
> The generic naming scheme for x86 system call entry points is:
>
> entry_MNEMONIC_qualifier
>
> where 'qualifier' is one of _32, _64 or _compat.
>
> Cc: Andy Lutomirski <luto@xxxxxxxxxxxxxx>
> Cc: Borislav Petkov <bp@xxxxxxxxx>
> Cc: Brian Gerst <brgerst@xxxxxxxxx>
> Cc: Denys Vlasenko <dvlasenk@xxxxxxxxxx>
> Cc: H. Peter Anvin <hpa@xxxxxxxxx>
> Cc: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>
> Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
> Cc: linux-kernel@xxxxxxxxxxxxxxx
> Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
> ---
> Documentation/x86/entry_64.txt | 4 ++--
> arch/x86/entry/entry_64_compat.S | 8 ++++----
> arch/x86/entry/syscall_32.c | 6 +++---
> arch/x86/include/asm/proto.h | 4 ++--
> arch/x86/kernel/asm-offsets_64.c | 2 +-
> arch/x86/kernel/cpu/common.c | 2 +-
> arch/x86/kernel/traps.c | 2 +-
> arch/x86/xen/xen-asm_64.S | 2 +-
> 8 files changed, 15 insertions(+), 15 deletions(-)
>
> diff --git a/Documentation/x86/entry_64.txt b/Documentation/x86/entry_64.txt
> index 9132b86176a3..33884d156125 100644
> --- a/Documentation/x86/entry_64.txt
> +++ b/Documentation/x86/entry_64.txt
> @@ -18,10 +18,10 @@ The IDT vector assignments are listed in arch/x86/include/asm/irq_vectors.h.
>
> - system_call: syscall instruction from 64-bit code.
>
> - - ia32_syscall: int 0x80 from 32-bit or 64-bit code; compat syscall
> + - entry_INT80_compat: int 0x80 from 32-bit or 64-bit code; compat syscall
> either way.

Haha, with the new naming scheme you don't even need the text anymore.
entry_INT80_compat is already enough.

:-)

Looks like an improvement to me, at a quick glance.

--
Regards/Gruss,
Boris.

ECO tip #101: Trim your mails when you reply.
--
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/