Re: [PATCH 2/4] x86/asm/entry: Untangle 'ia32_sysenter_target' into two entry points: entry_SYSENTER_32 and entry_SYSENTER_compat

From: Andy Lutomirski
Date: Mon Jun 08 2015 - 20:13:56 EST


On Mon, Jun 8, 2015 at 1:34 AM, Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> So the SYSENTER instruction is pretty quirky and it has different behavior
> depending on bitness and CPU maker.
>
> Yet we create a false sense of coherency by naming it 'ia32_sysenter_target'
> in both of the cases.
>
> Split the name into its two uses:
>
> ia32_sysenter_target (32) -> entry_SYSENTER_32
> ia32_sysenter_target (64) -> entry_SYSENTER_compat
>

Now that I'm rebasing my pile on top of this, I have a minor gripe
about this one. There are (in my mind, anyway), two SYSENTER
instructions: the 32-bit one and the 64-bit one. (That is, there's
SYSENTER32, which happens when you do SYSENTER in 32-bit or compat
mode, and SYSENTER64, which happens when you do SYSENTER in long
mode.) SYSENTER32, from user code's perspective, does the same thing
in either case [1]. That means that it really does make sense that
we'd have two implementations of the same entry point, one written in
32-bit asm and one written in 64-bit asm.

The patch I'm rebasing merges the two wrmsrs to MSR_IA32_SYSENTER, and
this change makes it uglier.

[1] Sort of. We probably have differently nonsensical calling
conventions, but that's our fault and has nothing to do with the
hardware.

--Andy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/