Re: [PATCH v2 08/13] KVM: implement multiple address spaces

From: Xiao Guangrong
Date: Mon Jun 08 2015 - 23:24:25 EST




On 05/28/2015 01:05 AM, Paolo Bonzini wrote:

/*
@@ -772,6 +776,7 @@ int __kvm_set_memory_region(struct kvm *kvm,
struct kvm_memory_slot *slot;
struct kvm_memory_slot old, new;
struct kvm_memslots *slots = NULL, *old_memslots;
+ int as_id, id;
enum kvm_mr_change change;

r = check_memory_region_flags(mem);
@@ -779,24 +784,27 @@ int __kvm_set_memory_region(struct kvm *kvm,
goto out;

r = -EINVAL;
+ as_id = mem->slot >> 16;
+ id = mem->slot & 65535;
+

A minor comment, Could you put these decoding into a separate function?

Nice idea indeed.

Reviewed-by: Xiao Guangrong <guangrong.xiao@xxxxxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/