Re: [RFC 1/2] target: Add support for fabric IRQ completion

From: Christoph Hellwig
Date: Tue Jun 09 2015 - 03:27:33 EST


> diff --git a/drivers/target/target_core_tpg.c b/drivers/target/target_core_tpg.c
> index 3fbb0d4..aa08d6b 100644
> --- a/drivers/target/target_core_tpg.c
> +++ b/drivers/target/target_core_tpg.c
> @@ -37,6 +37,7 @@
>
> #include <target/target_core_base.h>
> #include <target/target_core_backend.h>
> +#include <target/target_core_configfs.h>
> #include <target/target_core_fabric.h>
>
> #include "target_core_internal.h"

This hunk look unrelated.

On the implementation: the new target_core_fabric_ops flag and
command flag aren't really needed, just add a version of
target_complete_cmd that takes the flag.

target_complete_irq is fairly misnamed as it doesn't get called
just from irq context, please chose a more sensible name for it.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/