[PATCH v2 00/17] x86/tsc: Clean up rdtsc helpers

From: Andy Lutomirski
Date: Fri Jun 12 2015 - 19:50:35 EST


My sincere apologies for the spam. I send an unholy mixture of the
real patch set and an old poorly split-up patch set, and the result
is incomprehensible. Here's what I meant to send.

After the some recent threads about rdtsc barriers, I remembered
that our RDTSC wrappers are a big mess. Let's clean it up.

Currently we have rdtscl, rdtscll, native_read_tsc,
paravirt_read_tsc, and rdtsc_barrier. For people who haven't
noticed rdtsc_barrier and who haven't carefully read the docs,
there's no indication that all of the other accessors have a giant
ordering gotcha. The macro forms are ugly, and the paravirt
implementation is completely pointless.

rdtscl is particularly awful. It reads the low bits. There are no
performance critical users of just the low bits anywhere in the
kernel.

Clean it up. After this patch set, there are exactly three
functions. rdtsc_unordered() is a function that does a raw RDTSC
and returns a 64-bit number. rdtsc_ordered() is a function that
does a properly ordered RDTSC for general-purpose use.
barrier_before_rdtsc() is exactly what it sounds like.

Andy Lutomirski (17):
x86/tsc: Inline native_read_tsc and remove __native_read_tsc
x86/msr/kvm: Remove vget_cycles()
x86/tsc/paravirt: Remove the read_tsc and read_tscp paravirt hooks
x86/tsc: Replace rdtscll with native_read_tsc
x86/tsc: Remove the rdtscp and rdtscpll macros
x86/tsc: Use the full 64-bit tsc in tsc_delay
x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug
baycom_epp: Replace rdtscl() with native_read_tsc()
staging/lirc_serial: Remove TSC-based timing
input/joystick/analog: Switch from rdtscl() to native_read_tsc()
drivers/input/gameport: Replace rdtscl() with native_read_tsc()
x86/tsc: Remove rdtscl()
x86/tsc: Rename native_read_tsc() to rdtsc_unordered()
x86/tsc: Move rdtsc_barrier() and rename it to barrier_before_rdtsc()
x86: Add rdtsc_ordered() and use it in trivial call sites
x86/tsc: Use rdtsc_ordered() in check_tsc_warp() and drop extra
barriers
x86/tsc: In read_tsc, use rdtsc_ordered() instead of get_cycles()

arch/x86/boot/compressed/aslr.c | 2 +-
arch/x86/entry/vdso/vclock_gettime.c | 16 +-----
arch/x86/include/asm/barrier.h | 11 ----
arch/x86/include/asm/msr.h | 63 +++++++++++++++-------
arch/x86/include/asm/paravirt.h | 34 ------------
arch/x86/include/asm/paravirt_types.h | 2 -
arch/x86/include/asm/pvclock.h | 8 +--
arch/x86/include/asm/stackprotector.h | 2 +-
arch/x86/include/asm/tsc.h | 18 +------
arch/x86/kernel/apb_timer.c | 8 +--
arch/x86/kernel/apic/apic.c | 8 +--
arch/x86/kernel/cpu/amd.c | 6 +--
arch/x86/kernel/cpu/mcheck/mce.c | 4 +-
arch/x86/kernel/espfix_64.c | 2 +-
arch/x86/kernel/hpet.c | 4 +-
arch/x86/kernel/paravirt.c | 2 -
arch/x86/kernel/paravirt_patch_32.c | 2 -
arch/x86/kernel/trace_clock.c | 7 +--
arch/x86/kernel/tsc.c | 12 ++---
arch/x86/kernel/tsc_sync.c | 14 +++--
arch/x86/kvm/lapic.c | 4 +-
arch/x86/kvm/svm.c | 4 +-
arch/x86/kvm/vmx.c | 4 +-
arch/x86/kvm/x86.c | 26 +++------
arch/x86/lib/delay.c | 13 ++---
arch/x86/um/asm/barrier.h | 4 +-
arch/x86/xen/enlighten.c | 3 --
drivers/input/gameport/gameport.c | 4 +-
drivers/input/joystick/analog.c | 4 +-
drivers/net/hamradio/baycom_epp.c | 2 +-
drivers/staging/media/lirc/lirc_serial.c | 63 ++--------------------
drivers/thermal/intel_powerclamp.c | 4 +-
.../power/cpupower/debug/kernel/cpufreq-test_tsc.c | 4 +-
33 files changed, 112 insertions(+), 252 deletions(-)

--
2.4.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/