Re: [RFC/INCOMPLETE 01/13] context_tracking: Add context_tracking_assert_state
From: Andy Lutomirski
Date: Wed Jun 17 2015 - 10:16:31 EST
On Wed, Jun 17, 2015 at 2:41 AM, Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> * Andy Lutomirski <luto@xxxxxxxxxx> wrote:
>> This will let us sprinkle sanity checks around the kernel without
>> making too much of a mess.
>> Signed-off-by: Andy Lutomirski <luto@xxxxxxxxxx>
>> include/linux/context_tracking.h | 8 ++++++++
>> 1 file changed, 8 insertions(+)
>> diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h
>> index 2821838256b4..0fbea4b152e1 100644
>> --- a/include/linux/context_tracking.h
>> +++ b/include/linux/context_tracking.h
>> @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev,
>> if (context_tracking_is_enabled())
>> __context_tracking_task_switch(prev, next);
>> +static inline void context_tracking_assert_state(enum ctx_state state)
>> + rcu_lockdep_assert(!context_tracking_is_enabled() ||
>> + this_cpu_read(context_tracking.state) == state,
>> + "context tracking state was wrong");
> Please don't introduce assert() style debug check interfaces!
> (And RCU should be fixed too I suspect.)
> They are absolutely horrible on the brain when mixed with WARN_ON() interfaces,
> which are the dominant runtime check interface in the kernel.
> Instead make it something like:
> #define ct_state() (this_cpu_read(context_tracking.state))
> #define CT_WARN_ON(cond) \
> WARN_ON(context_tracking_is_enabled() && (cond))
> and then the debug checks can be written as:
> CT_WARN_ON(ct_state() != CONTEXT_KERNEL);
> This is IMHO _far_ more readable than:
> (Assuming people will accept 'ct/CT' as an abbreviation for context tracking.)
Hmm, ok I guess. The part I don't like is having ct_state() at all on
non-context-tracking kernels -- it seems like it's asking for trouble.
We could make CT_WARN_ON not even evaluate its argument if
!CONFIG_CONTEXT_TRACKING, but then we still have ct_state() returning
garbage if !context_tracking_is_enabled().
The assert macro avoids all these problems despite being a bit ugly.
It's either a no-op returning void or it does the right thing.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/