Re: [PATCH 1/1] mm: move ->mremap() from file_operations to vm_operations_struct
From: Oleg Nesterov
Date: Tue Jun 23 2015 - 14:28:23 EST
On 06/23, Kirill A. Shutemov wrote:
> On Tue, Jun 23, 2015 at 08:02:51PM +0200, Oleg Nesterov wrote:
> > vma->vm_ops->mremap() looks more natural and clean in move_vma(),
> > and this way ->mremap() can have more users. Say, vdso.
> > Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>
> > ---
> > fs/aio.c | 25 ++++++++++++++++---------
> > include/linux/fs.h | 1 -
> > include/linux/mm.h | 1 +
> > mm/mremap.c | 4 ++--
> Please, update Documentation/filesystems/Locking.
OK, thanks, will do.
> > -static int aio_ring_remap(struct file *file, struct vm_area_struct *vma)
> > +static int aio_ring_remap(struct vm_area_struct *vma)
> I guess aio_ring_mremap() would be a better name.
OK, I'll wait for other comments then send v2 with these changes.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/