Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure

From: Oleg Nesterov
Date: Wed Jul 01 2015 - 18:43:34 EST


On 07/01, David Rientjes wrote:
>
> On Sat, 20 Jun 2015, Oleg Nesterov wrote:
>
> > move_vma() sets *locked even if move_page_tables() or ->mremap()
> > fails, change sys_mremap() to check "ret & ~PAGE_MASK".
> >
> > I think we should simply remove the VM_LOCKED code in move_vma(),
> > that is why this patch doesn't change move_vma(). But this needs
> > more cleanups.
> >
> > Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>
> > ---
> > mm/mremap.c | 4 +++-
> > 1 files changed, 3 insertions(+), 1 deletions(-)
> >
> > diff --git a/mm/mremap.c b/mm/mremap.c
> > index a6306bc..492721c 100644
> > --- a/mm/mremap.c
> > +++ b/mm/mremap.c
> > @@ -574,8 +574,10 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
> > ret = move_vma(vma, addr, old_len, new_len, new_addr, &locked);
> > }
> > out:
> > - if (ret & ~PAGE_MASK)
> > + if (ret & ~PAGE_MASK) {
> > vm_unacct_memory(charged);
> > + locked = 0;
> > + }
> > up_write(&current->mm->mmap_sem);
> > if (locked && new_len > old_len)
> > mm_populate(new_addr + old_len, new_len - old_len);
>
> Acked-by: David Rientjes <rientjes@xxxxxxxxxx>

Thanks! I am resending this series with your acks applies.

Plus another patche which was already acked but ignored anyway ;)

> Might be cleaner to rename this to "populate" in sys_mremap() and set it
> to false in the previous old_len >= new_len conditional and remove the
> check here for new_len > old_len.

Oh, this needs much more cleanups. Imo the whole VM_LOCKED logic in these
paths is ugly and confusing. move_vma() shouldn't look at VM_LOCKED at all,
mremap_to() should not duplicate the vma_to_resize/move_vma code, etc.

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/