Re: [PATCH 4/4] oom: split out forced OOM killer

From: David Rientjes
Date: Wed Jul 08 2015 - 19:41:36 EST


On Wed, 8 Jul 2015, Michal Hocko wrote:

> From: Michal Hocko <mhocko@xxxxxxx>
>
> The forced OOM killing is currently wired into out_of_memory() call
> even though their objective is different which makes the code ugly
> and harder to follow. Generic out_of_memory path has to deal with
> configuration settings and heuristics which are completely irrelevant
> to the forced OOM killer (e.g. sysctl_oom_kill_allocating_task or
> OOM killer prevention for already dying tasks). All of them are
> either relying on explicit force_kill check or indirectly by checking
> current->mm which is always NULL for sysrq+f. This is not nice, hard
> to follow and error prone.
>
> Let's pull forced OOM killer code out into a separate function
> (force_out_of_memory) which is really trivial now.
> As a bonus we can clearly state that this is a forced OOM killer
> in the OOM message which is helpful to distinguish it from the
> regular OOM killer.
>
> Signed-off-by: Michal Hocko <mhocko@xxxxxxx>

It's really absurd that we have to go through this over and over and that
your patches are actually being merged into -mm just because you don't get
the point.

We have no need for a force_out_of_memory() function. None whatsoever.
Keeping oc->force_kill around is just more pointless space on a very deep
stack and I'm tired of fixing stack overflows. I'm certainly not going to
introduce others because you think it looks cleaner in the code when
memory compaction does the exact same thing by using cc->order == -1 to
mean explicit compaction.

This is turning into a complete waste of time.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/