[PATCH 2/3] staging: fbtft: do not use magic numbers

From: Sudip Mukherjee
Date: Sat Sep 05 2015 - 09:44:19 EST


Using magic numbers are not good coding practise. Use
FBTFT_GPIO_NAME_SIZE as defined in the header files.

Signed-off-by: Sudip Mukherjee <sudip@xxxxxxxxxxxxxxx>
---
drivers/staging/fbtft/fbtft_device.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/fbtft/fbtft_device.c b/drivers/staging/fbtft/fbtft_device.c
index 3856c88..80ab918 100644
--- a/drivers/staging/fbtft/fbtft_device.c
+++ b/drivers/staging/fbtft/fbtft_device.c
@@ -1375,7 +1375,7 @@ static int __init fbtft_device_init(void)
}

/* name=list lists all supported displays */
- if (strncmp(name, "list", 32) == 0) {
+ if (strncmp(name, "list", FBTFT_GPIO_NAME_SIZE) == 0) {
pr_info(DRVNAME": Supported displays:\n");

for (i = 0; i < ARRAY_SIZE(displays); i++)
--
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/