Re: [PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK

From: Thomas Gleixner
Date: Thu Oct 01 2015 - 07:54:52 EST


On Mon, 28 Sep 2015, Dave Hansen wrote:
>
> /*
> @@ -916,7 +918,10 @@ static int spurious_fault_check(unsigned
>
> if ((error_code & PF_INSTR) && !pte_exec(*pte))
> return 0;
> -
> + /*
> + * Note: We do not do lazy flushing on protection key
> + * changes, so no spurious fault will ever set PF_PK.
> + */

It might be a bit more clear to have:

/* Comment .... */
if ((error_code & PF_PK))
return 1;

return 1;

That way the comment is associated to obviously redundant code, but
it's easier to read, especially if we add some new PF_ thingy after
that.

Other than that:

Reviewed-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/