Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct

From: Felipe Balbi
Date: Fri Oct 02 2015 - 13:37:58 EST


On Mon, Sep 21, 2015 at 05:01:17PM +0200, Peter Senna Tschudin wrote:
> For making the code more readable and to facilitate supporting multiple
> hardware versions, move #defines to outside the struct declaration. This
> patch also renames fhcd2xx_regs to fotg210_regs as this struct is
> specific to fotg210.
>
> Signed-off-by: Peter Senna Tschudin <peter.senna@xxxxxxxxx>
> ---
> drivers/usb/host/faraday-hcd.h | 137 ++++++++++++++++++++++-------------------
> 1 file changed, 74 insertions(+), 63 deletions(-)
>
> diff --git a/drivers/usb/host/faraday-hcd.h b/drivers/usb/host/faraday-hcd.h
> index cf29edf..f75c467 100644
> --- a/drivers/usb/host/faraday-hcd.h
> +++ b/drivers/usb/host/faraday-hcd.h
> @@ -85,7 +85,7 @@ struct fhcd2xx_hcd { /* one per controller */
>
> /* glue to PCI and HCD framework */
> struct fhcd2xx_caps __iomem *caps;
> - struct fhcd2xx_regs __iomem *regs;
> + struct fotg210_regs __iomem *regs;

should this be in previous patch ?

personally, I don't see what's the benefit of this patch, however not against it
either.

--
balbi

Attachment: signature.asc
Description: PGP signature