Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros

From: Ingo Molnar
Date: Mon Dec 07 2015 - 04:45:21 EST



* Borislav Petkov <bp@xxxxxxxxx> wrote:

> static int __init chacha20_simd_mod_init(void)
> {
> - if (!cpu_has_ssse3)
> + if (!boot_cpu_has(X86_FEATURE_SSSE3))
> return -ENODEV;

Btw., could we rename 'boot_cpu_has()' to the more appropriate (and shorter!)
'system_has()' form?

'boot cpu' is a conceptual misnomer here really: it's just an implementational
detail that we are looking at the boot CPU's flags, what we really mean to express
is that these are system-wide features with no per-cpu properties.

Agreed?

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/