Re: [PATCH v2] of/address: replace printk() with pr_debug() / pr_err()

From: Andy Shevchenko
Date: Wed Dec 09 2015 - 15:37:18 EST

On Wed, Dec 9, 2015 at 10:17 PM, Rasmus Villemoes
<linux@xxxxxxxxxxxxxxxxxx> wrote:
> On Wed, Dec 09 2015, Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote:
>> On Wed, Dec 9, 2015 at 9:28 PM, Joe Perches <joe@xxxxxxxxxxx> wrote:

>>> +enum {
>>> + DUMP_TYPE_CPU = 0,
>> And still open this, do we need it? I think you may just mention in
>> the documentation that default behaviour is CPU like.
> I think it's best to have a name for the default. In this case it's
> unlikely to ever be relevant, but in general one could imagine stuff
> like
> #ifdef THIS_OR_THAT
> #else
> #endif
> which is a lot more readable than if the latter was a naked 0.

Point taken.

Though _CPU suggests user to think if it's equivalent to BE or LE. I'm
wondering if _NATIVE is better?

With Best Regards,
Andy Shevchenko
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at