Re: [PATCH v3 06/17] perf build: Rename LIB_PATH -> API_PATH

From: Jiri Olsa
Date: Mon Dec 14 2015 - 05:34:49 EST


On Sun, Dec 13, 2015 at 10:18:06PM -0600, Josh Poimboeuf wrote:
> 'LIB_PATH' is a misnomer because there are multiple library paths.
>
> Signed-off-by: Josh Poimboeuf <jpoimboe@xxxxxxxxxx>

Acked-by: Jiri Olsa <jolsa@xxxxxxxxxx>

thanks,
jirka

> ---
> tools/perf/Makefile.perf | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/tools/perf/Makefile.perf b/tools/perf/Makefile.perf
> index 906c723..388ec64 100644
> --- a/tools/perf/Makefile.perf
> +++ b/tools/perf/Makefile.perf
> @@ -185,13 +185,13 @@ ifneq ($(OUTPUT),)
> TE_PATH=$(OUTPUT)
> BPF_PATH=$(OUTPUT)
> ifneq ($(subdir),)
> - LIB_PATH=$(OUTPUT)/../lib/api/
> + API_PATH=$(OUTPUT)/../lib/api/
> else
> - LIB_PATH=$(OUTPUT)
> + API_PATH=$(OUTPUT)
> endif
> else
> TE_PATH=$(TRACE_EVENT_DIR)
> - LIB_PATH=$(LIB_DIR)
> + API_PATH=$(LIB_DIR)
> BPF_PATH=$(BPF_DIR)
> endif
>
> @@ -201,7 +201,7 @@ export LIBTRACEEVENT
> LIBTRACEEVENT_DYNAMIC_LIST = $(TE_PATH)libtraceevent-dynamic-list
> LIBTRACEEVENT_DYNAMIC_LIST_LDFLAGS = -Xlinker --dynamic-list=$(LIBTRACEEVENT_DYNAMIC_LIST)
>
> -LIBAPI = $(LIB_PATH)libapi.a
> +LIBAPI = $(API_PATH)libapi.a
> export LIBAPI
>
> LIBBPF = $(BPF_PATH)libbpf.a
> --
> 2.4.3
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/