Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1
From: Ingo Molnar
Date: Mon Jan 11 2016 - 07:39:53 EST
* Borislav Petkov <bp@xxxxxxxxx> wrote:
> From: Borislav Petkov <bp@xxxxxxx>
> Hi guys,
> so what better time to do that fun than during the holidays when no one
> else is producing patches. :-)
> Anyway, here's a part one conversion of the AMD perf events facilities.
> Directory structure looks like this:
> |-- amd
> | |-- core.c
> | |-- ibs.c
> | |-- iommu.c
> | |-- iommu.h
> | `-- uncore.c
> |-- core.c
> `-- Makefile
> and I've kept the churn at a mininum. Holler if something's not kosher.
So it is only now that I noticed that we have both 'core.c' and 'uncore.c', which
is slightly bit confusing: the core.c's we have around the kernel denote core
subsystem functionality - not CPU core functionality. If we have uncore.c around,
confusion might ensue.
OTOH maybe it's not a big issue and we can just live with it. I'd hate to see
main.c. Maybe rename 'uncore.c' to 'cpu_uncore.c'? OTOH that sounds a bit silly
too. So maybe leave it as you named them.