[RFC 03/29] staging/android: rename sync_fence_release

From: Gustavo Padovan
Date: Fri Jan 15 2016 - 09:56:03 EST


From: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx>

To avoid collision with an upcoming rename change the name of
sync_fence_release() to sync_fence_release_file()

Signed-off-by: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx>
---
drivers/staging/android/sync.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index ed43796..4926bb0 100644
--- a/drivers/staging/android/sync.c
+++ b/drivers/staging/android/sync.c
@@ -534,7 +534,7 @@ static void sync_fence_free(struct kref *kref)
kfree(fence);
}

-static int sync_fence_release(struct inode *inode, struct file *file)
+static int sync_fence_file_release(struct inode *inode, struct file *file)
{
struct sync_fence *fence = file->private_data;

@@ -724,7 +724,7 @@ static long sync_fence_ioctl(struct file *file, unsigned int cmd,
}

static const struct file_operations sync_fence_fops = {
- .release = sync_fence_release,
+ .release = sync_fence_file_release,
.poll = sync_fence_poll,
.unlocked_ioctl = sync_fence_ioctl,
.compat_ioctl = sync_fence_ioctl,
--
2.5.0