Re: [PATCH v2] can: c_can: add xceiver enable/disable support
From: Marc Kleine-Budde
Date: Wed Jan 20 2016 - 09:29:16 EST
On 01/20/2016 03:11 PM, Kurt Van Dijck wrote:
>> diff --git a/drivers/net/can/c_can/c_can.c b/drivers/net/can/c_can/c_can.c
>> index f91b094..0723aeb 100644
>> --- a/drivers/net/can/c_can/c_can.c
>> +++ b/drivers/net/can/c_can/c_can.c
>> @@ -1263,6 +1271,10 @@ int register_c_can_dev(struct net_device *dev)
>> + priv->reg_xceiver = devm_regulator_get(priv->device, "xceiver");
> I assume "xceiver" is the shorter name for "transceiver"?
> In that case, I suggest changing the devicetree label to "transceiver".
> It would become a mess if different drivers use different names.
> I see no real benefit for naming it "xceiver". "trx" is even shorter :-)
> See also http://www.acronymfinder.com/TRX.html
> The internals, like variable names, do not really matter here.
> I haven't looked at other driver, yet the argument still stands.
The transceiver is named xceiver in all drivers.
Pengutronix e.K. | Marc Kleine-Budde |
Industrial Linux Solutions | Phone: +49-231-2826-924 |
Vertretung West/Dortmund | Fax: +49-5121-206917-5555 |
Amtsgericht Hildesheim, HRA 2686 | http://www.pengutronix.de |
Description: OpenPGP digital signature