Re: [PATCH v2] can: c_can: add xceiver enable/disable support
From: Markus Pargmann
Date: Wed Jan 20 2016 - 09:29:38 EST
On Wednesday 20 January 2016 15:11:51 Kurt Van Dijck wrote:
> > diff --git a/drivers/net/can/c_can/c_can.c b/drivers/net/can/c_can/c_can.c
> > index f91b094..0723aeb 100644
> > --- a/drivers/net/can/c_can/c_can.c
> > +++ b/drivers/net/can/c_can/c_can.c
> > @@ -1263,6 +1271,10 @@ int register_c_can_dev(struct net_device *dev)
> > */
> > pinctrl_pm_select_sleep_state(dev->dev.parent);
> > + priv->reg_xceiver = devm_regulator_get(priv->device, "xceiver");
> I assume "xceiver" is the shorter name for "transceiver"?
> In that case, I suggest changing the devicetree label to "transceiver".
> It would become a mess if different drivers use different names.
> I see no real benefit for naming it "xceiver". "trx" is even shorter :-)
> See also http://www.acronymfinder.com/TRX.html
> The internals, like variable names, do not really matter here.
> I haven't looked at other driver, yet the argument still stands.
Oh right and perhaps it is necessary to add some documentation for the
devicetree binding if it is not generic already? In that case the DT
mailing list is missing as well.
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
Description: This is a digitally signed message part.