Re: [PATCH v3 4/4] clk: s2mps11: remove redundant code
From: Krzysztof Kozlowski
Date: Wed Jan 20 2016 - 19:29:25 EST
On 20.01.2016 19:14, Andi Shyti wrote:
> The definition of s2mps11_name is meant to resolve the name of a
> given clock. Remove it because the clocks have the same name we
> can get it directly from the s2mps11_clks_init structure.
> While in the probe function the s2mps11_clks is used only to
> iterate through the s2mps11_clks. The naming itself brings
> confusion and the readability does not improve much.
> Signed-off-by: Andi Shyti <andi.shyti@xxxxxxxxxxx>
> drivers/clk/clk-s2mps11.c | 36 ++++++++++++++++--------------------
> 1 file changed, 16 insertions(+), 20 deletions(-)
Reviewed-by: Krzysztof Kozlowski <k.kozlowski@xxxxxxxxxxx>