Re: Nokia N900: musb is in wrong state after boot

From: Pali RohÃr
Date: Thu Jan 21 2016 - 03:40:19 EST

On Tuesday 19 January 2016 12:33:15 Tony Lindgren wrote:
> Hi,
> * Pali RohÃr <pali.rohar@xxxxxxxxx> [160109 07:16]:
> > Hello,
> >
> > when I boot 4.4.0-rc7+ kernel compiled with g_nokia into zImage on Nokia
> > N900 into userspace then usb gadget (g_nokia) does not work. Notebook,
> > connected on other side does not see any usb device... Connecting and
> > disconnecting cable does not change anything, still not work.
> >
> > But if I run this command
> > $ echo peripheral > /sys/bus/platform/devices/
> > then gadget starts working. Other side see usb device and can use it.
> > Also connecting and disconnecting usb cable working fine. After
> > connecting it again, usb device OK.
> N900 had the PHY interrupt wired to the bq chip instead of twl4030, right?

I do not know now. I tried to find it in N900 schemantics, but do not
see it.

CCing Joerg, do you know?

> You can fix this issue similar to phy-twl4030-usb.c. In function
> twl4030_phy_power_on() we call schedule_delayed_work() that checks
> the state of the ID pin on boot up.

I looked at that code, but do not see what and how can be fixed :-(

> I think that's only needed for the i2c based PHY's with MUSB, with
> the others the USB driver has a better idea of the current state.
> Regards,
> Tony

Pali RohÃr