Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers

From: H. Peter Anvin
Date: Thu Jan 21 2016 - 16:26:11 EST

On 01/21/16 13:21, Borislav Petkov wrote:
> On Thu, Jan 21, 2016 at 01:04:57PM -0800, H. Peter Anvin wrote:
>> I'm wondering, though, if it wouldn't be better to turn these into
>> macros so that they can be used in assembly code. That way the
>> definitions can be interspersed with the X86_FEATURE_ definitions,
>> too.
> What concrete use case do you have in mind, i.e., example?

See X86_CAPABILITY in head_32.S for example.