Re: [PATCH v2 8/10] cpufreq: governor: Rename cpu_common_dbs_info to policy_dbs_info

From: Viresh Kumar
Date: Fri Feb 05 2016 - 03:34:17 EST


On 05-02-16, 03:20, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
>
> The struct cpu_common_dbs_info structure represents the per-policy
> part of the governor data (for the ondemand and conservative
> governors), but its name doesn't reflect its purpose.
>
> Rename it to struct policy_dbs_info and rename variables related to
> it accordingly.
>
> No functional changes.
>
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
> ---
> drivers/cpufreq/cpufreq_governor.c | 120 ++++++++++++++++++-------------------
> drivers/cpufreq/cpufreq_governor.h | 8 +-
> drivers/cpufreq/cpufreq_ondemand.c | 32 ++++-----
> 3 files changed, 80 insertions(+), 80 deletions(-)
>
> Index: linux-pm/drivers/cpufreq/cpufreq_governor.h
> ===================================================================
> --- linux-pm.orig/drivers/cpufreq/cpufreq_governor.h
> +++ linux-pm/drivers/cpufreq/cpufreq_governor.h
> @@ -132,7 +132,7 @@ static void *get_cpu_dbs_info_s(int cpu)
> */
>
> /* Common to all CPUs of a policy */
> -struct cpu_common_dbs_info {
> +struct policy_dbs_info {
> struct cpufreq_policy *policy;
> /*
> * Per policy mutex that serializes load evaluation from limit-change
> @@ -162,7 +162,7 @@ struct cpu_dbs_info {
> */
> unsigned int prev_load;
> struct update_util_data update_util;
> - struct cpu_common_dbs_info *shared;
> + struct policy_dbs_info *shared;

You should replaced shared with policy_dbs here as well ? Apart from
that:

Acked-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>

--
viresh