Re: [PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

From: Richard Cochran
Date: Tue Feb 16 2016 - 02:52:22 EST


On Fri, Feb 12, 2016 at 12:25:24PM -0800, Christopher S. Hall wrote:
> The code in ktime_get_snapshot() is a superset of the code in
> ktime_get_raw_and_real() code. Further, ktime_get_raw_and_real() is
> called only by the PPS code, pps_get_ts(). Consolidate the
> pps_get_ts() code into a single function calling ktime_get_snapshot()
> and eliminate ktime_get_raw_and_real(). A side effect of this is that
> the raw and real results of pps_get_ts() correspond to exactly the
> same clock cycle. Previously these values represented separate reads
> of the system clock.

Nice improvement.

> @@ -888,6 +888,8 @@ void ktime_get_snapshot(struct system_time_snapshot *systime_snapshot)
> s64 nsec_real;
> cycle_t now;
>
> + WARN_ON(timekeeping_suspended);
...
> - WARN_ON_ONCE(timekeeping_suspended);

Is this change intentional?

Thanks,
Richard