Re: [PATCH v11 3/4] x86, mce: Add __mcsafe_copy()

From: Peter Zijlstra
Date: Thu Feb 18 2016 - 04:59:25 EST


On Thu, Feb 18, 2016 at 09:21:07AM +0100, Ingo Molnar wrote:
>
> * Tony Luck <tony.luck@xxxxxxxxx> wrote:
>
> > Make use of the EXTABLE_FAULT exception table entries. This routine
> > returns a structure to indicate the result of the copy:
>
> So the series looks good to me, but I have some (mostly readability) comments that
> went beyond what I usually fix up manually:
>
> > struct mcsafe_ret {
> > u64 trapnr;
> > u64 remain;
> > };
>
> > +struct mcsafe_ret {
> > + u64 trapnr;
> > + u64 remain;
> > +};
>
> Yeah, so please change this to something like:
>
> struct mcsafe_ret {
> u64 trap_nr;
> u64 bytes_left;
> };
>
> this makes it crystal clear what the fields are about and what their unit is.
> Readability is king and modern consoles are wide enough, no need to abbreviate
> excessively.

I prefer to use my modern console width to display multiple columns of
text, instead of wasting it to display mostly whitespace. Therefore I
still very much prefer ~80 char wide code.

> > +struct mcsafe_ret __mcsafe_copy(void *dst, const void __user *src, size_t cnt);
> > +extern void __mcsafe_copy_end(void);
>
> So this is a bad name I think. What kind of 'copy' is this? It's defined in
> asm/string_64.h - so people might thing it's a string copy. If it's a memcpy
> variant then name it so.
>
> Also, I'd suggest we postfix the new mcsafe functions with '_mcsafe', not prefix
> them. Special properties of memcpy routines are usually postfixes - such as
> _nocache(), _toio(), etc.

I think the whole notion of mcsafe here is 'wrong'. This copy variant
simply reports the kind of trap that happened (#PF or #MC) and could
arguably be extended to include more types if the hardware were to
generate more.