Re: [RESEND PATCH 0/5] perf core: Support overwrite ring buffer

From: Ingo Molnar
Date: Tue Mar 08 2016 - 10:29:39 EST

* Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:

> Here's a thread on syz-kaller:
> If things have shifted again I'm sure Dmitry is willing to help.

So I tried to install 'go' but it's a _really_ unintuitive tool I have to say.

I installed golang-go on Ubuntu, which gave me a 'go' command:

triton:~> go version
go version go1.5.1 linux/amd64

that was the only step that worked. It's a dead end from that point on:

triton:~> go get
package cannot download, $GOPATH not set. For more details see: go help gopath

ok, so lets set GOPATH to the distro src directory:

triton:~> export GOPATH=/usr/lib/go/src/
triton:~> go get
package mkdir /usr/lib/go/src/src: permission denied

btw., this is what the directory contains:

triton:~> ls /usr/lib/go/src/
all.bash bootstrap.bash bytes compress debug flag html io make.bat nacltest.bash race.bash run.bash strconv testing unsafe
all.bat bufio clean.bash container encoding fmt image iostest.bash Make.dist net race.bat run.bat strings text
androidtest.bash buildall.bash clean.bat crypto errors go index log math os reflect runtime sync time
archive builtin cmd database expvar hash internal make.bash mime path regexp sort syscall unicode

so, according to the error message it wants a writable directory. Lets try it that

triton:~> mkdir go
triton:~> export GOPATH=/home/mingo/go/
triton:~> go get
can't load package: package no buildable Go source files in /home/mingo/go/src/

looks like someone wants 'Go' to be used as little as possible! ;-)