Re: [PATCH v9 2/3] kernel.h: add to_user_ptr()

From: Gustavo Padovan
Date: Thu Mar 17 2016 - 14:05:39 EST

2016-03-17 Joe Perches <joe@xxxxxxxxxxx>:

> On Thu, 2016-03-17 at 14:30 -0300, Gustavo Padovan wrote:
> > This function had copies in 3 different files. Unify them in
> > kernel.h.
> This is only used by gpu/drm.
> I think this is a poor name for a generic function
> that would be in kernel.h.
> Isn't there an include file in linux/drm that's
> appropriate for this.  Maybe drmP.h
> Maybe prefix this function name with drm_ too.

No, the next patch adds a user to drivers/staging (which will be moved
to drivers/dma-buf) soon. Maybe move to a different header in
include/linux/? not sure which one.

> Also, there's this that might conflict:
> arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p)          ptr_to_compat(p)
> arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p)          ((unsigned long)(p))

Right, I'll figure out how to replace these two too.