Re: KASAN overhead?

From: Valdis . Kletnieks
Date: Sat Mar 19 2016 - 21:15:43 EST

On Sat, 19 Mar 2016 13:13:59 +0100, Alexander Potapenko said:

> Which GCC version were you using? Are you sure it didn't accidentally
> enable the outline instrumentation (e.g. if the compiler is too old)?

gcc --version
gcc (GCC) 6.0.0 20160311 (Red Hat 6.0.0-0.16)

* Fri Mar 11 2016 Jakub Jelinek <jakub@xxxxxxxxxx> 6.0.0-0.15
- update from the trunk

Doesn't get much newer than that.. :) (Hmm.. possibly *too* new?)

> > and saw an *amazing* slowdown.
> Have you tried earlier KASAN versions? Is this a recent regression?

First time I'd tried it, so no comparison point..

> Was KASAN reporting anything between these lines? Sometimes a recurring
> warning slows everything down.

Nope, it didn't report a single thing.

> How did it behave after the startup? Was it still slow?

After seeing how long it took to get to a single-user prompt, I didn't
investigate further. It took 126 seconds to get here:

[ 126.937247] audit: type=1327 audit(1458268293.617:100): proctitle="/usr/sbin/sulogin"

compared to the more usual:

[ 29.249260] audit: type=1327 audit(1458326938.276:100): proctitle="/usr/sbin/sulogin"

(In both cases, there's a 10-12 second pause for entering a LUKS
passphrase, so we're looking at about 110 seconds with KASAN versus
about 17-18 without.)

> Which machine were you using? Was it a real device or a VM?

Running native on a Dell Latitude laptop....

(Based on the fact that you're asking questions rather than just saying
it's expected behavior, I'm guessing I've once again managed to find
a corner case of some sort. I'm more than happy to troubleshoot, if
you can provide hints of what to try...)

Attachment: pgp7mkR5AnHqA.pgp
Description: PGP signature