Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall()

From: Ingo Molnar
Date: Tue Apr 19 2016 - 07:15:46 EST

* tip-bot for Dmitry Safonov <tipbot@xxxxxxxxx> wrote:

> Commit-ID: abfb9498ee1327f534df92a7ecaea81a85913bae
> Gitweb:
> Author: Dmitry Safonov <dsafonov@xxxxxxxxxxxxx>
> AuthorDate: Mon, 18 Apr 2016 16:43:43 +0300
> Committer: Ingo Molnar <mingo@xxxxxxxxxx>
> CommitDate: Tue, 19 Apr 2016 10:44:52 +0200
> x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall()

Btw., I'm not _entirely_ happy about the 'IA32' name, but went with this name for
lack of a better alternative.

So we have 4 system call modes:

- 64-bit native
- 32-bit addresses with 64-bit arguments (x32)
- 32-bit compat syscall (x86-32 compatibility on x86-64)
- 32-bit native

and we have 2 bits of data that are per system call properties:

- TS_COMPAT in thread_info->status is set/cleared dynamically by the compat
syscall entry code

- a high bit in pt_regs->orig_ax tells us whether it's an x32 system call.

So I'd suggest the following renames to harmonize these concepts:

this lines up nicely with: CONFIG_X86_X32_ABI

- is_ia32_syscall() -> is_x86_32_syscall()
- is_x32_syscall() -> is_x86_x32_syscall()

- is_compat_syscall() remains as-is.

... thoughts?