Re: [PATCH v3 0/2] Align mmap address for DAX pmd mappings
From: Matthew Wilcox
Date: Thu Apr 21 2016 - 20:22:17 EST
On Thu, Apr 21, 2016 at 07:43:39PM -0400, Toshi Kani wrote:
> On 4/21/2016 4:21 PM, Mike Kravetz wrote:
> >Might want to keep the future possibility of PUD_SIZE THP in mind?
> Yes, this is why the func name does not say 'pmd'. It can be extended to
> PUD_SIZE in future.
Sure ... but what does that look like? I think it should look a little
unsigned long __thp_get_unmapped_area(struct file *filp, unsigned long len,
loff_t off, unsigned long flags, unsigned long size);
unsigned long addr;
loff_t off_end = off + len;
loff_t off_align = round_up(off, size);
unsigned long len_size;
if ((off_end <= off_align) || ((off_end - off_align) < size))
len_size = len + size;
if ((len_size < len) || (off + len_size) < off)
addr = current->mm->get_unmapped_area(filp, NULL, len_size,
off >> PAGE_SHIFT, flags);
addr += (off - addr) & (size - 1);
unsigned long thp_get_unmapped_area(struct file *filp, unsigned long addr,
unsigned long len, unsigned long pgoff, unsigned long flags)
loff_t off = (loff_t)pgoff << PAGE_SHIFT;
if (IS_DAX(filp->f_mapping->host) && !IS_ENABLED(CONFIG_FS_DAX_PMD))
/* Kirill, please fill in the right condition here for THP pagecache */
addr = __thp_get_unmapped_area(filp, len, off, flags, PUD_SIZE);
addr = __thp_get_unmapped_area(filp, len, off, flags, PMD_SIZE);
return current->mm->get_unmapped_area(filp, addr, len, pgoff, flags);
By the way, I added an extra check here, when we add len and size
(PMD_SIZE in the original), we need to make sure that doesn't wrap.
NB: I'm not even compiling these suggestions, just throwing them out
here as ideas to be criticised.
Also, len_size is a stupid name, but I can't think of a better one.