Re: [PATCH v11 12/17] ARM64: ACPI: Check if it runs on Xen to enable or disable ACPI

From: Mark Rutland
Date: Fri Apr 22 2016 - 06:33:03 EST


On Wed, Apr 20, 2016 at 10:34:41AM +0100, Stefano Stabellini wrote:
> Hello Mark,
>
> do you think that this patch addresses your previous comments
> (http://marc.info/?l=devicetree&m=145926913008544&w=2) appropriately?
>
> Thanks,
>
> Stefano
>
> On Thu, 7 Apr 2016, Shannon Zhao wrote:
> > From: Shannon Zhao <shannon.zhao@xxxxxxxxxx>
> >
> > When it's a Xen domain0 booting with ACPI, it will supply a /chosen and
> > a /hypervisor node in DT. So check if it needs to enable ACPI.
> >
> > Signed-off-by: Shannon Zhao <shannon.zhao@xxxxxxxxxx>
> > Reviewed-by: Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
> > Acked-by: Hanjun Guo <hanjun.guo@xxxxxxxxxx>
> > ---
> > arch/arm64/kernel/acpi.c | 14 ++++++++++----
> > 1 file changed, 10 insertions(+), 4 deletions(-)
> >
> > diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
> > index d1ce8e2..57ee317 100644
> > --- a/arch/arm64/kernel/acpi.c
> > +++ b/arch/arm64/kernel/acpi.c
> > @@ -67,10 +67,15 @@ static int __init dt_scan_depth1_nodes(unsigned long node,
> > {
> > /*
> > * Return 1 as soon as we encounter a node at depth 1 that is
> > - * not the /chosen node.
> > + * not the /chosen node, or /hypervisor node with compatible
> > + * string "xen,xen".
> > */
> > - if (depth == 1 && (strcmp(uname, "chosen") != 0))
> > - return 1;
> > + if (depth == 1 && (strcmp(uname, "chosen") != 0)) {
> > + if (strcmp(uname, "hypervisor") != 0 ||
> > + !of_flat_dt_is_compatible(node, "xen,xen"))
> > + return 1;
> > + }
> > +
> > return 0;
> > }

Is the duplicate node checking logic I mentioned in that review gone?
i.e. do we not need an is_xen_node() helper?

Additionally, IMO, this would be easier to follow without the nested
conditionals, e.g.

static int __init dt_scan_depth1_nodes(unsigned long node,
const char *uname, int depth,
void *data)
{
/*
* Ignore anything not directly under the root node; we'll
* catch its parent instead.
*/
if (depth != 1)
return 0;

if (strcmp(uname, "chosen") == 0)
return 0;

if (strcmp(uname, "hypervisor") == 0 &&
of_flat_dt_is_compatible(node, "xen,xen"))
return 0;

/*
* This node at depth 1 is neither a chosen node nor a xen node,
* which we do not expect.
*/
return 1;
}

Otherwise, this looks fine to me. FWIW, either way:

Acked-by: Mark Rutland <mark.rutland@xxxxxxx>

As this is core arm64 code, I believe you'll need acks from Catalin
and/or Will (and likewise for patch 15), unless I've missed those.

Thanks,
Mark.

> >
> > @@ -184,7 +189,8 @@ void __init acpi_boot_table_init(void)
> > /*
> > * Enable ACPI instead of device tree unless
> > * - ACPI has been disabled explicitly (acpi=off), or
> > - * - the device tree is not empty (it has more than just a /chosen node)
> > + * - the device tree is not empty (it has more than just a /chosen node,
> > + * and a /hypervisor node when running on Xen)
> > * and ACPI has not been force enabled (acpi=force)
> > */
> > if (param_acpi_off ||
> > --
> > 2.0.4
> >
> >
>