Re: [PATCH 1/6] statx: Add a system call to make enhanced file info available

From: Trond Myklebust
Date: Mon May 09 2016 - 09:39:17 EST







On 5/9/16, 08:57, "linux-nfs-owner@xxxxxxxxxxxxxxx on behalf of David Howells" <linux-nfs-owner@xxxxxxxxxxxxxxx on behalf of dhowells@xxxxxxxxxx> wrote:

>Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:
>
>> > int ret = statx(int dfd,
>> > const char *filename,
>> > unsigned int flags,
>> > unsigned int mask,
>> > struct statx *buffer);
>>
>> Please move the flags and mask after the buffer, similar to how all
>> the AT_ flags were added to the end for the statat calls.
>
>Sure, if you really want.
>
>> > AT_FORCE_ATTR_SYNC can be set in flags. This will require a network
>> > filesystem to synchronise its attributes with the server.
>> >
>> > AT_NO_ATTR_SYNC can be set in flags. This will suppress synchronisation
>> > with the server in a network filesystem. The resulting values should be
>> > considered approximate.
>>
>> And what happens if neither is set?
>
>It does what stat() does now, whatever that is for each fs. The assumption is
>that this might be used to emulate stat() from userspace. However, we want to
>be able to make sure we get the two behaviours above.
>
>> > mask is a bitmask indicating the fields in struct statx that are of
>> > interest to the caller. The user should set this to STATX_BASIC_STATS to
>> > get the basic set returned by stat().
>>
>> No a very good name for the constant. I don't really see how this macro
>> is useful to start with.
>
>It's the bits that correspond to all the data in the the current stat struct.
>So if you want to emulate stat(), you should pass this in mask.
>
>> And _ALL? sure, but what's basic?
>
>Actually, _ALL is perhaps the less useful of the two since the bitset is not
>closed. OTOH - anything not in _ALL won't be listed explicitly in the
>structure, but would rather consume space space.
>
>> > st_gen is
>> > the inode generation number, st_btime is the file creation time, st_version
>> > is the data version number (i_version),
>>
>> Please define semantics for st_gen and st_version.
>
>I've been asked to drop st_gen for security reasons.
>
>I can't offhand think of a way to define st_version (or i_version, for that
>matter) that would be consistent across all filesystems. I would lean towards
>"gets incremented monotonically by 1 for each data write operation committed,
>but not for any metadata operations", but I'm fairly certain this won't jibe
>with disk operations. So I can leave it out for now and bring it back if we
>find a real user for it.

The NFSv4 definition for the change attribute (which is mapped to i_version when IS_I_VERSION(inode) is true) is

"A value created by the server that the client can use to determine if
file data, directory contents, or attributes of the object have been
modified. The server may return the object's time_metadata attribute
for this attribute's value, but only if the file system object cannot
be updated more frequently than the resolution of time_metadata."


IOW: it is a value that changes on all data and metadata operations, and with no monotonicity requirement. Iâm pretty sure all userspace NFSv4 servers out there would like to access it (e.g. Ganesha, dCache).

>
>> > Time fields are split into separate seconds and nanoseconds fields to make
>> > packing easier and the granularities can be queried with the filesystem
>> > info system call. Note that times will be negative if before 1970; in such
>> > a case, the nanosecond fields should also be negative if not zero.
>>
>> Please coordinate with Arnd on the timespamp format - I'd hate to have
>> a different encoding than he plans for all y2028/64-bit-time_t syscalls
>> to be added soon.
>
>I have discussed this with him previously.
>
>> > STATX_VERSION Want/got st_data_version
>>
>> What is st_data_version?
>
>Sorry, that should've been st_version. It got renamed.
>
>> > STATX_GEN Want/got st_gen
>> > STATX_ALL_STATS [All currently available stuff]
>>
>> Where does the STATS_ come from? Why no simply _ALL?
>
>Why not STATX_ALL_STATS?
>
>David
>--
>To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
>the body of a message to majordomo@xxxxxxxxxxxxxxx
>More majordomo info at http://vger.kernel.org/majordomo-info.html
>