Re: [PATCH v2 1/1] x86/platform/intel-mid: Add Power Management Unit driver

From: Ingo Molnar
Date: Wed Jun 15 2016 - 04:15:44 EST



* Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:

> Add Power Management Unit driver to handle power states of South Complex
> devices on Intel Tangier. In the future it might be expanded to cover North
> Complex devices as well.
>
> With this driver the power state of the host controllers such as SPI, I2C,
> UART, eMMC, and DMA would be managed.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
> In v2:
> - rename *pmu* to *pwr*
> - fix indentation to be consistent for definitions
> - add comments to explain what driver does
> - refactor quirks in intel_mid_pci.c
>
> arch/x86/include/asm/intel-mid.h | 8 +
> arch/x86/pci/intel_mid_pci.c | 40 +++-
> arch/x86/platform/intel-mid/Makefile | 2 +-
> arch/x86/platform/intel-mid/pwr.c | 416 +++++++++++++++++++++++++++++++++++
> drivers/pci/Makefile | 3 +
> drivers/pci/pci-mid.c | 77 +++++++
> 6 files changed, 540 insertions(+), 6 deletions(-)
> create mode 100644 arch/x86/platform/intel-mid/pwr.c
> create mode 100644 drivers/pci/pci-mid.c

I've applied this to tip:x86/platform. I changed references to 'PMU' to 'PWRMU' -
let me know if you'd like to use some other abbreviation.

Please send the clean-up patch on top of this. (Feel free to squash the one I sent
into yours.)

Thanks,

Ingo