Re: [PATCH v2 3/4] input: touchscreen: mxs-lradc: Add support for touchscreen

From: Stefan Wahren
Date: Wed Jun 15 2016 - 17:26:50 EST


Hi,

unfortunately i still don't have a touchscreen to test this patch.

> Ksenija Stanojevic <ksenija.stanojevic@xxxxxxxxx> hat am 8. Juni 2016 um 16:48
> geschrieben:
>
>
> Add 4-wire/5-wire touchscreen controller.
>
> Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@xxxxxxxxx>
> ---
> Changes in v2:
> - do not change spacing in Kconfig
> - remove dev.parent
> - rename err_ts_register to error
> - combine functions hw_stop and disable_ts so that mxs_lradc_ts_remove
> could be deleted.
> - add spinlock in struct mxs_lradc_ts to enable locking in interrupt handler.
> - only grab irqs that are relevant to touchscreen
> - use direct return instead assigning error to touch_ret in probe function.
> - change licence to GPL
> - add copyright
>
> drivers/input/touchscreen/Kconfig | 10 +
> drivers/input/touchscreen/Makefile | 1 +
> drivers/input/touchscreen/mxs-lradc-ts.c | 726
> +++++++++++++++++++++++++++++++
> 3 files changed, 737 insertions(+)
> create mode 100644 drivers/input/touchscreen/mxs-lradc-ts.c
>
> diff --git a/drivers/input/touchscreen/mxs-lradc-ts.c
> b/drivers/input/touchscreen/mxs-lradc-ts.c
> new file mode 100644
> index 0000000..778bb61
> --- /dev/null
> +++ b/drivers/input/touchscreen/mxs-lradc-ts.c
> @@ -0,0 +1,726 @@
> +/*
> + * Freescale MXS LRADC driver

touchscreen driver

> + *
> + * Copyright (c) 2012 DENX Software Engineering, GmbH.
> + * Marek Vasut <marex@xxxxxxx>
> + * Ksenija Stanojevic <ksenija.stanojevic@xxxxxxxxx>
> + *
> + * This program is free software; you can redistribute it and/or modify
> + * it under the terms of the GNU General Public License as published by
> + * the Free Software Foundation; either version 2 of the License, or
> + * (at your option) any later version.
> + *
> + * This program is distributed in the hope that it will be useful,
> + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> + * GNU General Public License for more details.
> + */
> +
> ...
> +
> +static struct platform_driver mxs_lradc_ts_driver = {
> + .driver = {
> + .name = DRIVER_NAME_TS,
> + },
> + .probe = mxs_lradc_ts_probe,
> +};
> +module_platform_driver(mxs_lradc_ts_driver);
> +

MODULE_DESCRIPTION ?
MODULE_AUTHOR ?

> +MODULE_LICENSE("GPL");
> --
> 1.9.1
>