Re: [PATCH 2/3] x86: add some better documentation for probe_kernel_address()

From: Andy Lutomirski
Date: Fri Jul 22 2016 - 14:10:40 EST

On Jul 22, 2016 11:03 AM, "Dave Hansen" <dave@xxxxxxxx> wrote:
> From: Dave Hansen <dave.hansen@xxxxxxxxxxxxxxx>
> probe_kernel_address() has an unfortunate name since it is used
> to probe kernel *and* userspace addresses. Add a comment
> explaining some of the situation to help the next developer who
> might make the silly assumption that it is for probing kernel
> addresses.

This can't work on architectures like s390 that have separate,
overlapping user and kernel address spaces. Maybe we should fix x86
to stop abusing it and use get_user instead. (In which case, your new
function should be called get_user_insn_byte or similar.)